映画とネットのDIARY(tDiary版)

since 2004/07/15
ここは古い日記です。2013年11月からadiaryを使った新サイトに移行しました。
2004年7月15日以前の日記は「映画とネットのDIARY(hnsバージョン)」にあります。
検索エンジンからのアクセスで、お探しのキーワードが見あたらない場合はNamazuで再検索してみてください。
映画の感想一覧】 2000年  2001年  2002年  2003年 2004年7月以前
2004年7月以降 2005年  2006年  2007年  2008年  2009年

2013年05月19日 [Sun]

bit.lyのAPI

TwitterがURLの短縮を自動で行うようになったので、あまり使い道がないが、bit.lyを使ってURLを短縮するプログラムをなでしこで書いてみた。既に短縮してあれば、元のURLに変換する。bit.lyのAPIキーはhttps://bitly.com/a/your_api_keyからサインアップして取得できる。

ロングURL=#短縮あるいはデコードするURL
ログインID=#bit.lyのログインID
APIキー=#APIキー
ロングURLを「http://bit.ly/\w.*」で正規表現一致
もし、それが1ならば、
 対象タグは「long_url」
 対象URLは「http://api.bitly.com/v3/expand?shortUrl={ロングURL}&login={ログインID}&apiKey={APIキー}&format=xml」
違えば、
 対象タグは「url」
 対象URLは「http://api.bitly.com/v3/shorten?longUrl={ロングURL}&login={ログインID}&apiKey={APIキー}&format=xml」
経過ダイアログはオフ
エラー監視
 「{対象URL}」をHTTPデータ取得
 bitはそれ
エラーならば、
 「短縮URLを取得できませんでした。」と言う
 戻る
bitで「{対象タグ}」をタグ切り出し
「<{対象タグ}>(.*)</{対象タグ}>」を「$1」に正規表現単置換
短縮URLはそれ

同じ機能の秀丸マクロ・短縮URL作成マクロ は200行以上ある。なでしこだと簡単だ。


[管理人にメールする] [シネマ1987online]